USB62405 C# Programming Manual: USB62405 Directory Reference

USB62405 C# Programming Manual
  • USB62405
USB62405 Directory Reference

Files

file | JYUSB62405AITask.cs
file | JYUSB62405CITask.cs
file | JYUSB62405COTask.cs
file | JYUSB62405DITask.cs
file | JYUSB62405DOTask.cs
Generated by doxygen 1.9.1


USB62405 C# Programming Manual: USB62405/JYUSB62405AITask.cs File Reference

  • USB62405
Classes | Namespaces | Enumerations
JYUSB62405AITask.cs File Reference

Classes

class | JYUSB62405.JYUSB62405AITask
AI采集任务类,是Sealed类，不可被继承 More...
class | JYUSB62405.AIChannel
AI通道参数类 More...
class | JYUSB62405.AITrigger
触发参数 More...
class | JYUSB62405.AIDigitalTrigger
数字触发参数 More...
class | JYUSB62405.AIAnalogTrigger
模拟触发参数 More...
class | JYUSB62405.AIAdvanced
AI高级参数设置 More...

Namespaces

namespace JYUSB62405

Enumerations

enum class | JYUSB62405.Coupling { JYUSB62405.AC , JYUSB62405.DC }
耦合方式枚举类型 More...
enum class | JYUSB62405.AITriggerType { JYUSB62405.Immediate , JYUSB62405.Digital , JYUSB62405.Analog }
AI触发类型，需要根据板卡的实际支持情况修改 More...
enum class | JYUSB62405.AIClockEdge { JYUSB62405.Rising , JYUSB62405.Falling }
AI时钟沿类型 More...
enum class | JYUSB62405.AIDigitalTriggerEdge { JYUSB62405.Rising , JYUSB62405.Falling , JYUSB62405.Low , JYUSB62405.High }
AI触发沿类型 More...
enum class | JYUSB62405.AIDigitalTriggerSource { JYUSB62405.GPIO0 }
数字触发信号源 More...
enum class | JYUSB62405.AIAnalogTriggerSource { JYUSB62405.CH0 , JYUSB62405.CH1 , JYUSB62405.CH2 , JYUSB62405.CH3 }
模拟触发信号源 More...
enum class | JYUSB62405.AIMode { JYUSB62405.Single , JYUSB62405.Finite , JYUSB62405.Continuous }
AI工作模式枚举类型 More...
enum class | JYUSB62405.AITerminal { JYUSB62405.Differential , JYUSB62405.Pseudodifferential }
输入配置枚举类型 More...
enum class | JYUSB62405.AIClockSource { JYUSB62405.Internal , JYUSB62405.External }
时钟源类型 More...
enum class | JYUSB62405.AITriggerMode { JYUSB62405.Start , JYUSB62405.Reference , JYUSB62405.Pause }
触发模式 More...
enum class | JYUSB62405.AIAnalogTriggerCondition { JYUSB62405.AboveLevel , JYUSB62405.BelowLevel }
模拟触发的触发条件 More...


USB62405 C# Programming Manual: JYUSB62405.JYUSB62405AITask Class Reference

  • JYUSB62405
  • JYUSB62405AITask
Public Member Functions | Properties | List of all members
JYUSB62405.JYUSB62405AITask Class Reference

AI采集任务类,是Sealed类，不可被继承 More...

Public Member Functions

JYUSB62405AITask (int boardNum)
This creates AI task. More...
void | AddChannel (int channelID, double rangeLow=-10, double rangeHigh=10, Coupling coupling=Coupling.DC, AITerminal terminal=AITerminal.Differential, bool enableIEPE=false)
添加通道 More...
void | AddChannel (int[] channelsID, double rangeLow=-10, double rangeHigh=10, Coupling coupling=Coupling.DC, AITerminal terminal=AITerminal.Differential, bool enableIEPE=false)
添加多通道 More...
void | AddChannel (int[] channelsID, double[] rangeLow, double[] rangeHigh, Coupling coupling=Coupling.DC, AITerminal terminal=AITerminal.Differential, bool enableIEPE=false)
添加多通道,每通道量程可设置不同 More...
void | RemoveChannel (int channelID)
删除指定通道号的通道,为-1则删除所有通道 More...
void | ReadData (ref double[,] buf, int timeout)
读取数据，按列返回采集到的电压值 More...
void | ReadData (ref double[,] buf, int samplesPerChannel, int timeout)
读取数据，按列返回采集到的电压值 More...
void | ReadData (ref double[] buf, int timeout)
读取数据，按列返回采集到的电压值 More...
void | ReadData (ref double[] buf, int samplesPerChannel, int timeout)
读取数据，按列返回采集到的电压值 More...
void | ReadData (IntPtr buf, int samplesPerChannel, int timeout)
读取数据，按列返回采集到的电压值 More...
void | ReadRawData (IntPtr buf, int samplesPerChannel, int timeout)
读取数据，按列返回采集到的电压值,返回单通道的数据 More...
void | ReadRawData (ref int[,] buf, int timeout)
读取数据，按列返回采集到的电压值 More...
void | ReadRawData (ref int[,] buf, int samplesPerChannel, int timeout)
读取数据，按列返回采集到的电压值,返回单通道的数据 More...
void | ReadRawData (ref int[] buf, int timeout)
读取数据，按列返回采集到的电压值 More...
void | ReadRawData (ref int[] buf, int samplesPerChannel, int timeout)
读取数据，按列返回采集到的电压值 More...
void | ReadSinglePoint (ref double[] buffer)
每通道读取一个样点，非缓冲式读取。返回应用变换系数变换后的数据。 More...
void | ReadSinglePoint (ref double readValue)
单通道读取一个样点，非缓冲式读取。返回应用变换系数变换后的数据。 More...
bool | WaitUntilDone (int timeout)
等待当前任务完成 More...
void | Start ()
启动数采任务 More...
void | Stop ()
停止数采任务 More...

Properties

List< AIChannel > | Channels [get]
通道列表 More...
AIMode | Mode [get, set]
采集模式，支持Single/Finite/Continuous三种类型 More...
double | SampleRate [get, set]
每通道采样率 More...
int | SamplesToAcquire [get, set]
有限点采集时, 每通道采集的样点数。若设置为小于0，则采集无穷个点。 More...
int | BufLenInSamples [get, set]
缓冲区能容纳的每通道样点数。一次读取的样点数不能超过此容量。
More...
int | AvailableSamples [get]
缓冲区内可以读取的点数 More...
AIClockSource | ClkSource [get, set]
时钟源,需要根据不同厂商驱动的规定去修改EnumClkSrc枚举 More...
AIClockEdge | ClockEdge [get, set]
时钟沿。仅在外部时钟时有效。 More...
AITrigger | Trigger [get, set]
AI触发参数设置 More...
AIAdvanced | Advanced [get]
AI高级参数设置 More...

Detailed Description

AI采集任务类,是Sealed类，不可被继承

Constructor & Destructor Documentation

◆ JYUSB62405AITask()

JYUSB62405.JYUSB62405AITask.JYUSB62405AITask ( int boardNum )

This creates AI task.

User supplies , sample rates and samples per channel , AIMode , AIClkSrc , clkEdge , triggerType Some defaults:sampleRate = 1000 , samplesPerChannel = 1024 Finite Model, Internal clock source; Immediate trigger Finite acquisition, internal source clock, rising edge, immediate triggering

Parameters
boardNum Hardware boardNum

Member Function Documentation

◆ AddChannel() [1/3]

void JYUSB62405.JYUSB62405AITask.AddChannel | ( | int | channelID,
 |  | double | rangeLow = -10,
 |  | double | rangeHigh = 10,
 |  | Coupling | coupling = Coupling.DC,
 |  | AITerminal | terminal = AITerminal.Differential,
 |  | bool | enableIEPE = false
 | ) |  |

添加通道

Parameters
channelID | 通道物理序号
rangeLow | 通道量程下限
rangeHigh | 通道量程上限
coupling | 耦合方式
terminal | 端口输入模式配置
enableIEPE | 使能IEPE激励
Returns

◆ AddChannel() [2/3]

void JYUSB62405.JYUSB62405AITask.AddChannel | ( | int[] | channelsID,
 |  | double | rangeLow = -10,
 |  | double | rangeHigh = 10,
 |  | Coupling | coupling = Coupling.DC,
 |  | AITerminal | terminal = AITerminal.Differential,
 |  | bool | enableIEPE = false
 | ) |  |

添加多通道

Parameters
channelsID | 要添加通道的所有物理序号
rangeLow | 通道量程下限
rangeHigh | 通道量程上限
coupling | 耦合方式
terminal | 端口输入模式配置
enableIEPE | 使能IEPE激励
Returns

◆ AddChannel() [3/3]

void JYUSB62405.JYUSB62405AITask.AddChannel | ( | int[] | channelsID,
 |  | double[] | rangeLow,
 |  | double[] | rangeHigh,
 |  | Coupling | coupling = Coupling.DC,
 |  | AITerminal | terminal = AITerminal.Differential,
 |  | bool | enableIEPE = false
 | ) |  |

添加多通道,每通道量程可设置不同

Parameters
channelsID | 要添加通道的所有物理序号
rangeLow | 通道量程下限
rangeHigh | 通道量程上限
coupling | 耦合方式
terminal | 端口输入模式配置
enableIEPE | 使能IEPE激励
Returns

◆ ReadData() [1/5]

void JYUSB62405.JYUSB62405AITask.ReadData | ( | IntPtr | buf,
 |  | int | samplesPerChannel,
 |  | int | timeout
 | ) |  |

读取数据，按列返回采集到的电压值

Parameters
buf | 用户缓冲区数组
samplesPerChannel | 用户缓冲区能容纳的每通道样点数
timeout | 当数据不足时，最多等待的时间（单位：ms）

  • 若缓冲区内可读取数据量达到SamplesPerChannel，则直接读取数据；否则，参考下一条。
  • 若任务已结束，则直接读取缓冲区内的剩余数据；否则，参考下一条。
  • 等待数据，在timeout时间内，若数据量达到SamplesPerChannel，则直接读取数据；否则，参考下一条。
  • 若等待timeout时间后，缓冲区数据量仍未达到SamplesPerChannel，则抛出超时异常；抛出异常前，依据Deterministic的值，若为false，则读取缓冲区内的所有数据，否则不读取数据。
Returns
小于0：实际错误代码 大于0：实际读到的每通道点数

◆ ReadData() [2/5]

void JYUSB62405.JYUSB62405AITask.ReadData | ( | ref double | buf[,],
 |  | int | samplesPerChannel,
 |  | int | timeout
 | ) |  |

读取数据，按列返回采集到的电压值

Parameters
buf | 用户缓冲区数组
samplesPerChannel | 用户缓冲区能容纳的每通道样点数
timeout | 当数据不足时，最多等待的时间（单位：ms）

  • 若缓冲区内可读取数据量达到SamplesPerChannel，则直接读取数据；否则，参考下一条。
  • 若任务已结束，则直接读取缓冲区内的剩余数据；否则，参考下一条。
  • 等待数据，在timeout时间内，若数据量达到SamplesPerChannel，则直接读取数据；否则，参考下一条。
  • 若等待timeout时间后，缓冲区数据量仍未达到SamplesPerChannel，则抛出超时异常；抛出异常前，依据Deterministic的值，若为false，则读取缓冲区内的所有数据，否则不读取数据。
Returns
小于0：实际错误代码 大于0：实际读到的每通道点数

◆ ReadData() [3/5]

void JYUSB62405.JYUSB62405AITask.ReadData | ( | ref double | buf[,],
 |  | int | timeout
 | ) |  |

读取数据，按列返回采集到的电压值

Parameters
buf | 用户缓冲区数组
timeout | 当数据不足时，最多等待的时间（单位：ms）

  • 若缓冲区内可读取数据量达到SamplesPerChannel，则直接读取数据；否则，参考下一条。
  • 若任务已结束，则直接读取缓冲区内的剩余数据；否则，参考下一条。
  • 等待数据，在timeout时间内，若数据量达到SamplesPerChannel，则直接读取数据；否则，参考下一条。
  • 若等待timeout时间后，缓冲区数据量仍未达到SamplesPerChannel，则抛出超时异常；抛出异常前，依据Deterministic的值，若为false，则读取缓冲区内的所有数据，否则不读取数据。
Returns
小于0：实际错误代码 大于0：实际读到的每通道点数

◆ ReadData() [4/5]

void JYUSB62405.JYUSB62405AITask.ReadData | ( | ref double[] | buf,
 |  | int | samplesPerChannel,
 |  | int | timeout
 | ) |  |

读取数据，按列返回采集到的电压值

Parameters
buf | 用户缓冲区数组
samplesPerChannel | 用户缓冲区能容纳的每通道样点数
timeout | 当数据不足时，最多等待的时间（单位：ms）
  • 若缓冲区内可读取数据量达到SamplesPerChannel，则直接读取数据；否则，参考下一条。
  • 若任务已结束，则直接读取缓冲区内的剩余数据；否则，参考下一条。
  • 等待数据，在timeout时间内，若数据量达到SamplesPerChannel，则直接读取数据；否则，参考下一条。
  • 若等待timeout时间后，缓冲区数据量仍未达到SamplesPerChannel，则抛出超时异常；抛出异常前，依据Deterministic的值，若为false，则读取缓冲区内的所有数据，否则不读取数据。

Returns
小于0：实际错误代码 大于0：实际读到的每通道点数

◆ ReadData() [5/5]

void JYUSB62405.JYUSB62405AITask.ReadData | ( | ref double[] | buf,
 |  | int | timeout
 | ) |  |

读取数据，按列返回采集到的电压值

Parameters
buf | 用户缓冲区数组
timeout | 当数据不足时，最多等待的时间（单位：ms）
  • 若缓冲区内可读取数据量达到SamplesPerChannel，则直接读取数据；否则，参考下一条。
  • 若任务已结束，则直接读取缓冲区内的剩余数据；否则，参考下一条。
  • 等待数据，在timeout时间内，若数据量达到SamplesPerChannel，则直接读取数据；否则，参考下一条。
  • 若等待timeout时间后，缓冲区数据量仍未达到SamplesPerChannel，则抛出超时异常；抛出异常前，依据Deterministic的值，若为false，则读取缓冲区内的所有数据，否则不读取数据。

Returns
小于0：实际错误代码 大于0：实际读到的每通道点数

◆ ReadRawData() [1/5]

void JYUSB62405.JYUSB62405AITask.ReadRawData | ( | IntPtr | buf,
 |  | int | samplesPerChannel,
 |  | int | timeout
 | ) |  |

读取数据，按列返回采集到的电压值,返回单通道的数据

Parameters
buf | 用户缓冲区数组
samplesPerChannel | 用户缓冲区能容纳的每通道样点数
timeout | 超时时间

  • 若缓冲区内可读取数据量达到SamplesPerChannel，则直接读取数据；否则，参考下一条。
  • 若任务已结束，则直接读取缓冲区内的剩余数据；否则，参考下一条。
  • 等待数据，在timeout时间内，若数据量达到SamplesPerChannel，则直接读取数据；否则，参考下一条。
  • 若等待timeout时间后，缓冲区数据量仍未达到SamplesPerChannel，则抛出超时异常；抛出异常前，依据Deterministic的值，若为false，则读取缓冲区内的所有数据，否则不读取数据。

◆ ReadRawData() [2/5]

void JYUSB62405.JYUSB62405AITask.ReadRawData | ( | ref int | buf[,],
 |  | int | samplesPerChannel,
 |  | int | timeout
 | ) |  |

读取数据，按列返回采集到的电压值,返回单通道的数据

Parameters
buf | 用户缓冲区数组
samplesPerChannel | 用户缓冲区能容纳的每通道样点数
timeout | 超时时间

  • 若缓冲区内可读取数据量达到SamplesPerChannel，则直接读取数据；否则，参考下一条。
  • 若任务已结束，则直接读取缓冲区内的剩余数据；否则，参考下一条。
  • 等待数据，在timeout时间内，若数据量达到SamplesPerChannel，则直接读取数据；否则，参考下一条。
  • 若等待timeout时间后，缓冲区数据量仍未达到SamplesPerChannel，则抛出超时异常；抛出异常前，依据Deterministic的值，若为false，则读取缓冲区内的所有数据，否则不读取数据。

◆ ReadRawData() [3/5]

void JYUSB62405.JYUSB62405AITask.ReadRawData | ( | ref int | buf[,],
 |  | int | timeout
 | ) |  |

读取数据，按列返回采集到的电压值

Parameters
buf | 用户缓冲区数组
timeout | 超时时间

  • 若缓冲区内可读取数据量达到SamplesPerChannel，则直接读取数据；否则，参考下一条。
  • 若任务已结束，则直接读取缓冲区内的剩余数据；否则，参考下一条。
  • 等待数据，在timeout时间内，若数据量达到SamplesPerChannel，则直接读取数据；否则，参考下一条。
  • 若等待timeout时间后，缓冲区数据量仍未达到SamplesPerChannel，则抛出超时异常；抛出异常前，依据Deterministic的值，若为false，则读取缓冲区内的所有数据，否则不读取数据。
Returns
小于0：实际错误代码 大于0：实际读到的每通道点数

◆ ReadRawData() [4/5]

void JYUSB62405.JYUSB62405AITask.ReadRawData | ( | ref int[] | buf,
 |  | int | samplesPerChannel,
 |  | int | timeout
 | ) |  |

读取数据，按列返回采集到的电压值

Parameters
buf | 用户缓冲区数组
samplesPerChannel | 用户缓冲区能容纳的每通道样点数
timeout | 超时时间

  • 若缓冲区内可读取数据量达到SamplesPerChannel，则直接读取数据；否则，参考下一条。
  • 若任务已结束，则直接读取缓冲区内的剩余数据；否则，参考下一条。
  • 等待数据，在timeout时间内，若数据量达到SamplesPerChannel，则直接读取数据；否则，参考下一条。
  • 若等待timeout时间后，缓冲区数据量仍未达到SamplesPerChannel，则抛出超时异常；抛出异常前，依据Deterministic的值，若为false，则读取缓冲区内的所有数据，否则不读取数据。

///

Returns
小于0：实际错误代码 大于0：实际读到的每通道点数

◆ ReadRawData() [5/5]

void JYUSB62405.JYUSB62405AITask.ReadRawData | ( | ref int[] | buf,
 |  | int | timeout
 | ) |  |

读取数据，按列返回采集到的电压值

Parameters
buf | 用户缓冲区数组
timeout | 超时时间

  • 若缓冲区内可读取数据量达到SamplesPerChannel，则直接读取数据；否则，参考下一条。
  • 若任务已结束，则直接读取缓冲区内的剩余数据；否则，参考下一条。
  • 等待数据，在timeout时间内，若数据量达到SamplesPerChannel，则直接读取数据；否则，参考下一条。
  • 若等待timeout时间后，缓冲区数据量仍未达到SamplesPerChannel，则抛出超时异常；抛出异常前，依据Deterministic的值，若为false，则读取缓冲区内的所有数据，否则不读取数据。
Returns
小于0：实际错误代码 大于0：实际读到的每通道点数

◆ ReadSinglePoint() [1/2]

void JYUSB62405.JYUSB62405AITask.ReadSinglePoint ( ref double readValue )

单通道读取一个样点，非缓冲式读取。返回应用变换系数变换后的数据。

Parameters
readValue 用户缓冲区数组。数组大小须不小于NumOfChns。
Returns

◆ ReadSinglePoint() [2/2]

void JYUSB62405.JYUSB62405AITask.ReadSinglePoint ( ref double[] buffer )

每通道读取一个样点，非缓冲式读取。返回应用变换系数变换后的数据。

Parameters
buffer 用户缓冲区数组。数组大小须不小于NumOfChns。
Returns

◆ RemoveChannel()

void JYUSB62405.JYUSB62405AITask.RemoveChannel ( int channelID )

删除指定通道号的通道,为-1则删除所有通道

Parameters
channelID 要删除的通道的通道号

◆ Start()

void JYUSB62405.JYUSB62405AITask.Start ( )

启动数采任务

Returns
0: 成功

-507：内存不足；

-1：超时，任务未结束

-508: API调用次序不符合要求，或者参数异常

根据配置启动任务

◆ Stop()

void JYUSB62405.JYUSB62405AITask.Stop ( )

停止数采任务

Returns
0: 成功

-507：内存不足；

-1：超时，任务未结束

-508: API调用次序不符合要求，或者参数异常

停止正在执行的任务

◆ WaitUntilDone()

bool JYUSB62405.JYUSB62405AITask.WaitUntilDone ( int timeout )

等待当前任务完成

Parameters
timeout 等待的时间(单位:ms)

若设置为-1，则无限期等待；

若设置为0，则立即返回检查结果。

Property Documentation

◆ Advanced

AIAdvanced JYUSB62405.JYUSB62405AITask.Advanced
get

AI高级参数设置

◆ AvailableSamples

int JYUSB62405.JYUSB62405AITask.AvailableSamples
get

缓冲区内可以读取的点数

◆ BufLenInSamples

int JYUSB62405.JYUSB62405AITask.BufLenInSamples
getset

缓冲区能容纳的每通道样点数。一次读取的样点数不能超过此容量。

在调用 Start() 方法后分配或者调整缓冲区。

◆ Channels

List<AIChannel> JYUSB62405.JYUSB62405AITask.Channels
get

通道列表

◆ ClkSource

AIClockSource JYUSB62405.JYUSB62405AITask.ClkSource
getset

时钟源,需要根据不同厂商驱动的规定去修改EnumClkSrc枚举

◆ ClockEdge

AIClockEdge JYUSB62405.JYUSB62405AITask.ClockEdge
getset

时钟沿。仅在外部时钟时有效。

◆ Mode

AIMode JYUSB62405.JYUSB62405AITask.Mode
getset

采集模式，支持Single/Finite/Continuous三种类型

◆ SampleRate

double JYUSB62405.JYUSB62405AITask.SampleRate
getset

每通道采样率

◆ SamplesToAcquire

int JYUSB62405.JYUSB62405AITask.SamplesToAcquire
getset

有限点采集时, 每通道采集的样点数。若设置为小于0，则采集无穷个点。

默认值为256

◆ Trigger

AITrigger JYUSB62405.JYUSB62405AITask.Trigger
getset

AI触发参数设置

The documentation for this class was generated from the following file:
  • USB62405/JYUSB62405AITask.cs


USB62405 C# Programming Manual: JYUSB62405.AIChannel Class Reference

  • AIChannel
Properties | List of all members
JYUSB62405.AIChannel Class Reference

AI通道参数类 More...

Properties

Int32 | ChannelID [get]
通道号。与AI通道的物理序号相对应。 More...
double | RangeLow [get, set]
通道量程下限 More...
double | RangeHigh [get, set]
通道量程上限 More...
Coupling | Coupling [get, set]
耦合方式 More...
AITerminal | Terminal [get, set]
端口模式配置 More...
bool | EnableIEPE [get, set]
是否使能IEPE More...

Detailed Description

AI通道参数类

Property Documentation

◆ ChannelID

Int32 JYUSB62405.AIChannel.ChannelID
get

通道号。与AI通道的物理序号相对应。

◆ Coupling

Coupling JYUSB62405.AIChannel.Coupling
getset

耦合方式

◆ EnableIEPE

bool JYUSB62405.AIChannel.EnableIEPE
getset

是否使能IEPE

◆ RangeHigh

double JYUSB62405.AIChannel.RangeHigh
getset

通道量程上限

◆ RangeLow

double JYUSB62405.AIChannel.RangeLow
getset

通道量程下限

◆ Terminal

AITerminal JYUSB62405.AIChannel.Terminal
getset

端口模式配置

The documentation for this class was generated from the following file:
  • USB62405/JYUSB62405AITask.cs


USB62405 C# Programming Manual: JYUSB62405.AITrigger Class Reference

  • AITrigger
Properties | List of all members
JYUSB62405.AITrigger Class Reference

触发参数 More...

Properties

AITriggerType | Type [get, set]
触发类型，可能包括 Immediate/Software/Digital/Analog More...
AITriggerMode | Mode [get, set]
AI触发模式，包括Start触发和Reference触发 More...
AIDigitalTrigger | Digital [get, set]
数字触发参数设置 More...
AIAnalogTrigger | Analog [get, set]
模拟触发设置 More...
int | ReTriggerCount [get, set]
重复触发设置,为0时不重复触发，>0时为重复触发次数，-1时为无限次重触发； More...
double | Delay [get, set]
触发延迟时间设置，为0时不延迟，>0时为延迟ms数； More...
uint | PreTriggerSamples [get, set]
预触发点数，为0时无预触发，>0时为预触发点数； More...

Detailed Description

触发参数

Property Documentation

◆ Analog

AIAnalogTrigger JYUSB62405.AITrigger.Analog
getset

模拟触发设置

◆ Delay

double JYUSB62405.AITrigger.Delay
getset

触发延迟时间设置，为0时不延迟，>0时为延迟ms数；

◆ Digital

AIDigitalTrigger JYUSB62405.AITrigger.Digital
getset

数字触发参数设置

◆ Mode

AITriggerMode JYUSB62405.AITrigger.Mode
getset

AI触发模式，包括Start触发和Reference触发

◆ PreTriggerSamples

uint JYUSB62405.AITrigger.PreTriggerSamples
getset

预触发点数，为0时无预触发，>0时为预触发点数；

◆ ReTriggerCount

int JYUSB62405.AITrigger.ReTriggerCount
getset

重复触发设置,为0时不重复触发，>0时为重复触发次数，-1时为无限次重触发；

◆ Type

AITriggerType JYUSB62405.AITrigger.Type
getset

触发类型，可能包括 Immediate/Software/Digital/Analog

The documentation for this class was generated from the following file:
  • USB62405/JYUSB62405AITask.cs


USB62405 C# Programming Manual: JYUSB62405.AIDigitalTrigger Class Reference

  • AIDigitalTrigger
Properties | List of all members
JYUSB62405.AIDigitalTrigger Class Reference

数字触发参数 More...

Properties

AIDigitalTriggerSource | Source [get]
AI 数字触发信号源 More...
AIDigitalTriggerEdge | Edge [get, set]
AI 数字触发边沿类型，Rising/Falling More...

Detailed Description

数字触发参数

Property Documentation

◆ Edge

AIDigitalTriggerEdge JYUSB62405.AIDigitalTrigger.Edge
getset

AI 数字触发边沿类型，Rising/Falling

◆ Source

AIDigitalTriggerSource JYUSB62405.AIDigitalTrigger.Source
get

AI 数字触发信号源

The documentation for this class was generated from the following file:
  • USB62405/JYUSB62405AITask.cs


USB62405 C# Programming Manual: JYUSB62405.AIAnalogTrigger Class Reference

  • AIAnalogTrigger
Properties | List of all members
JYUSB62405.AIAnalogTrigger Class Reference

模拟触发参数 More...

Properties

AIAnalogTriggerSource | Source [get, set]
AI 模拟触发源 More...
AIAnalogTriggerCondition | Condition [get, set]
AI 模拟触发条件 More...
double | Threshold [get, set]
电平阈值 More...

Detailed Description

模拟触发参数

Property Documentation

◆ Condition

AIAnalogTriggerCondition JYUSB62405.AIAnalogTrigger.Condition
getset

AI 模拟触发条件

◆ Source

AIAnalogTriggerSource JYUSB62405.AIAnalogTrigger.Source
getset

AI 模拟触发源

◆ Threshold

double JYUSB62405.AIAnalogTrigger.Threshold
getset

电平阈值

The documentation for this class was generated from the following file:
  • USB62405/JYUSB62405AITask.cs


USB62405 C# Programming Manual: JYUSB62405.AIAdvanced Class Reference

  • AIAdvanced
Properties | List of all members
JYUSB62405.AIAdvanced Class Reference

AI高级参数设置 More...

Properties

double BufferLengthInSecond [get, set]

Detailed Description

AI高级参数设置

Property Documentation

◆ BufferLengthInSecond

double JYUSB62405.AIAdvanced.BufferLengthInSecond
getset

the buffer length in second,

Max=5.0s

Min=0.1s

The documentation for this class was generated from the following file:
  • USB62405/JYUSB62405AITask.cs


USB62405 C# Programming Manual: USB62405/JYUSB62405CITask.cs File Reference

  • USB62405
Classes | Namespaces
JYUSB62405CITask.cs File Reference

Classes

class JYUSB62405.JYUSB62405CITask
CI任务 More...

Namespaces

namespace JYUSB62405


USB62405 C# Programming Manual: JYUSB62405.JYUSB62405CITask Class Reference

  • JYUSB62405CITask
Public Member Functions | List of all members
JYUSB62405.JYUSB62405CITask Class Reference

CI任务 More...

Public Member Functions

JYUSB62405CITask (int boardNum, int channelID)
构造函数 More...
void | Start ()
开始任务 More...
void | Stop ()
void | ReadCounter (ref uint buf)

Detailed Description

CI任务

Constructor & Destructor Documentation

◆ JYUSB62405CITask()

JYUSB62405.JYUSB62405CITask.JYUSB62405CITask | ( | int | boardNum,
 |  | int | channelID
 | ) |  |

构造函数

Parameters
boardNum | 板卡ID号
channelID | 计数器编号，0或者1有效

Member Function Documentation

◆ ReadCounter()

void JYUSB62405.JYUSB62405CITask.ReadCounter ( ref uint buf )

Parameters
buf

◆ Start()

void JYUSB62405.JYUSB62405CITask.Start ( )

开始任务

◆ Stop()

void JYUSB62405.JYUSB62405CITask.Stop ( )

The documentation for this class was generated from the following file:
  • USB62405/JYUSB62405CITask.cs


USB62405 C# Programming Manual: USB62405/JYUSB62405COTask.cs File Reference

  • USB62405
Classes | Namespaces | Enumerations
JYUSB62405COTask.cs File Reference

Classes

class | JYUSB62405.JYUSB62405COTask
CO操作任务类 More...
class | JYUSB62405.DutyCycleFrequency
按占空比和频率设置 More...
class | JYUSB62405.Time
按高低电平时间设置 More...
class | JYUSB62405.Tick
按高低电平Tick设置 More...
class | JYUSB62405.COPulse
CO脉冲的参数设置 More...

Namespaces

namespace JYUSB62405

Enumerations

enum class | JYUSB62405.COSignalLevel { JYUSB62405.Low , JYUSB62405.High }
信号电平枚举，可选择项为low和High More...
enum class | JYUSB62405.COPolarity : ushort { JYUSB62405.LowActive = USB62405Import.GPTC_OUTPUT_LACTIVE , JYUSB62405.HighActive = USB62405Import.GPTC_OUTPUT_HACTIVE }
极性设置枚举，可选择项为LowActive和HighActive More...
enum class | JYUSB62405.COMode { JYUSB62405.ContGatedPulseGen = USB62405Import.ContGatedPulseGen , JYUSB62405.MultipleGatedPulseGen = USB62405Import.MultipleGatedPulseGen }
应用类型枚举，有8种模式，可选项为 SingleGatedPulseGen(Gate使能单脉冲生成），SingleTrigPulseGen（触发单脉冲生成）， RetrigSinglePulseGen（重触发单脉冲生成） SingleTrigContPulseGen（触发单脉冲生成），ContGatedPulseGen（Gate使能连续脉冲生成），MultipleGatedPulseGen（多门使能脉冲生成）。SingleTrigContPulseGenPWM（触发连续脉冲PWM连续脉冲生成）， ContGatedPulseGenPWM（门使能连续脉冲PWM生成） More...
enum class | JYUSB62405.COPulseType { JYUSB62405.DutyCycleFrequency , JYUSB62405.HighLowTime , JYUSB62405.HighLowTick }
CO输出脉冲参数的设置类型 More...


USB62405 C# Programming Manual: JYUSB62405.JYUSB62405COTask Class Reference

  • JYUSB62405COTask
Public Member Functions | Properties | List of all members
JYUSB62405.JYUSB62405COTask Class Reference

CO操作任务类 More...

Public Member Functions

JYUSB62405COTask (int boardNum, int chnId)
创建CO任务 More...
void | ApplyParam ()
应用参数配置（PWM生成时可以同时修改频率和占空比） More...
void | Start ()
启动CO任务 More...
void | Stop ()
停止Count Out 任务 More...

Properties

COMode | Mode [get, set]
应用类型，有8种模式，可选项为 SingleGatedPulseGen(Gate使能单脉冲生成），SingleTrigPulseGen（触发单脉冲生成）， RetrigSinglePulseGen（重触发单脉冲生成） SingleTrigContPulseGen（触发单脉冲生成），ContGatedPulseGen（Gate使能连续脉冲生成），MultipleGatedPulseGen（多门使能脉冲生成）。SingleTrigContPulseGenPWM（触发连续脉冲PWM连续脉冲生成）， ContGatedPulseGenPWM（门使能连续脉冲PWM生成） More...
COPulse | Pulse [get, set]
脉冲参数设置 More...

Detailed Description

CO操作任务类

Constructor & Destructor Documentation

◆ JYUSB62405COTask()

JYUSB62405.JYUSB62405COTask.JYUSB62405COTask | ( | int | boardNum,
 |  | int | chnId
 | ) |  |

创建CO任务

Parameters
boardNum | 设备编号
chnId | 需要用于脉冲生成的通道编号，可选择0和2

Member Function Documentation

◆ ApplyParam()

void JYUSB62405.JYUSB62405COTask.ApplyParam ( )

应用参数配置（PWM生成时可以同时修改频率和占空比）

◆ Start()

void JYUSB62405.JYUSB62405COTask.Start ( )

启动CO任务

◆ Stop()

void JYUSB62405.JYUSB62405COTask.Stop ( )

停止Count Out 任务

Property Documentation

◆ Mode

COMode JYUSB62405.JYUSB62405COTask.Mode
getset

应用类型，有8种模式，可选项为 SingleGatedPulseGen(Gate使能单脉冲生成），SingleTrigPulseGen（触发单脉冲生成）， RetrigSinglePulseGen（重触发单脉冲生成） SingleTrigContPulseGen（触发单脉冲生成），ContGatedPulseGen（Gate使能连续脉冲生成），MultipleGatedPulseGen（多门使能脉冲生成）。SingleTrigContPulseGenPWM（触发连续脉冲PWM连续脉冲生成）， ContGatedPulseGenPWM（门使能连续脉冲PWM生成）

◆ Pulse

COPulse JYUSB62405.JYUSB62405COTask.Pulse
getset

脉冲参数设置

The documentation for this class was generated from the following file:
  • USB62405/JYUSB62405COTask.cs


USB62405 C# Programming Manual: JYUSB62405.DutyCycleFrequency Class Reference

  • DutyCycleFrequency
Properties | List of all members
JYUSB62405.DutyCycleFrequency Class Reference

按占空比和频率设置 More...

Properties

double | DutyCycle [get, set]
输出脉冲的占空比 More...
double | Frequency [get, set]
输出脉冲的频率 More...

Detailed Description

按占空比和频率设置

Property Documentation

◆ DutyCycle

double JYUSB62405.DutyCycleFrequency.DutyCycle
getset

输出脉冲的占空比

◆ Frequency

double JYUSB62405.DutyCycleFrequency.Frequency
getset

输出脉冲的频率

The documentation for this class was generated from the following file:
  • USB62405/JYUSB62405COTask.cs


USB62405 C# Programming Manual: JYUSB62405.Time Class Reference

  • Time
Properties | List of all members
JYUSB62405.Time Class Reference

按高低电平时间设置 More...

Properties

double | High [get, set]
脉冲高电平时间 More...
double | Low [get, set]
脉冲低电平时间 More...

Detailed Description

按高低电平时间设置

Property Documentation

◆ High

double JYUSB62405.Time.High
getset

脉冲高电平时间

◆ Low

double JYUSB62405.Time.Low
getset

脉冲低电平时间

The documentation for this class was generated from the following file:
  • USB62405/JYUSB62405COTask.cs


USB62405 C# Programming Manual: JYUSB62405.Tick Class Reference

  • Tick
Properties | List of all members
JYUSB62405.Tick Class Reference

按高低电平Tick设置 More...

Properties

double | High [get, set]
脉冲高电平Tick More...
double | Low [get, set]
脉冲低电平Tick More...

Detailed Description

按高低电平Tick设置

Property Documentation

◆ High

double JYUSB62405.Tick.High
getset

脉冲高电平Tick

◆ Low

double JYUSB62405.Tick.Low
getset

脉冲低电平Tick

The documentation for this class was generated from the following file:
  • USB62405/JYUSB62405COTask.cs


USB62405 C# Programming Manual: JYUSB62405.COPulse Class Reference

  • COPulse
Properties | List of all members
JYUSB62405.COPulse Class Reference

CO脉冲的参数设置 More...

Properties

double | InitialDelay [get, set]
输出脉冲的初始延迟 More...
COPulseType | Type [get, set]
是否使用频率和占空比指定脉冲参数 More...
COPolarity | Polarity [get, set]
Pulse Output Polarity More...
DutyCycleFrequency | DutyCycleFrequency [get, set]
占空比和频率 More...
Time | Time [get, set]
高低电平时间 More...
Tick | Tick [get, set]
高低电平Tick数 More...
uint | Count [get, set]
输出脉冲的个数（仅针对MultipleGatedPulseGen模式） More...

Detailed Description

CO脉冲的参数设置

Property Documentation

◆ Count

uint JYUSB62405.COPulse.Count
getset

输出脉冲的个数（仅针对MultipleGatedPulseGen模式）

◆ DutyCycleFrequency

DutyCycleFrequency JYUSB62405.COPulse.DutyCycleFrequency
getset

占空比和频率

◆ InitialDelay

double JYUSB62405.COPulse.InitialDelay
getset

输出脉冲的初始延迟

◆ Polarity

COPolarity JYUSB62405.COPulse.Polarity
getset

Pulse Output Polarity

◆ Tick

Tick JYUSB62405.COPulse.Tick
getset

高低电平Tick数

◆ Time

Time JYUSB62405.COPulse.Time
getset

高低电平时间

◆ Type

COPulseType JYUSB62405.COPulse.Type
getset

是否使用频率和占空比指定脉冲参数

The documentation for this class was generated from the following file:
  • USB62405/JYUSB62405COTask.cs


USB62405 C# Programming Manual: USB62405/JYUSB62405DITask.cs File Reference

  • USB62405
Classes | Namespaces
JYUSB62405DITask.cs File Reference

Classes

class | JYUSB62405.JYUSB62405DITask
DIO操作任务类 More...
class | JYUSB62405.DIChannel
DIO通道参数类 More...

Namespaces

namespace JYUSB62405


USB62405 C# Programming Manual: JYUSB62405.JYUSB62405DITask Class Reference

  • JYUSB62405DITask
Public Member Functions | Properties | List of all members
JYUSB62405.JYUSB62405DITask Class Reference

DIO操作任务类 More...

Public Member Functions

JYUSB62405DITask (int boardNum)
构造函数 More...
void | AddChannel (int lineNum)
添加通道 More...
void | AddChannel (int[] lineNum)
添加通道 More...
void | RemoveChannel (int lineNum)
删除指定端口号和位号的通道。位号小于0时表示删除指定端口号的所有通道。 More...
void | Start ()
开始DI任务 More...
int | Stop ()
停止DI任务 More...
void | ReadSinglePoint (ref bool[] Buf)
每通道读取最新的一个点，非缓冲式读取。 More...

Properties

List< DIChannel > Channels [get]
通道列表 More...

Detailed Description

DIO操作任务类

Constructor & Destructor Documentation

◆ JYUSB62405DITask()

JYUSB62405.JYUSB62405DITask.JYUSB62405DITask ( int boardNum )

构造函数

Parameters
boardNum 板卡编号

Member Function Documentation

◆ AddChannel() [1/2]

void JYUSB62405.JYUSB62405DITask.AddChannel ( int lineNum )

添加通道

Parameters
lineNum 位号，从0开始。
Returns

◆ AddChannel() [2/2]

void JYUSB62405.JYUSB62405DITask.AddChannel ( int[] lineNum )

添加通道

Parameters
lineNum 位号，从0开始。小于0则添加整个端口。
Returns

◆ ReadSinglePoint()

void JYUSB62405.JYUSB62405DITask.ReadSinglePoint ( ref bool[] Buf )

每通道读取最新的一个点，非缓冲式读取。

Parameters
Buf 用户缓冲区数组。数组大小须不小于_channels.count。

◆ RemoveChannel()

void JYUSB62405.JYUSB62405DITask.RemoveChannel ( int lineNum )

删除指定端口号和位号的通道。位号小于0时表示删除指定端口号的所有通道。

Parameters
lineNum 端口中的位号,如果是null或在Length为0，则删除全部bit

◆ Start()

void JYUSB62405.JYUSB62405DITask.Start ( )

开始DI任务

Returns

◆ Stop()

int JYUSB62405.JYUSB62405DITask.Stop ( )

停止DI任务

Returns

Property Documentation

◆ Channels

List<DIChannel> JYUSB62405.JYUSB62405DITask.Channels
get

通道列表

The documentation for this class was generated from the following file:
  • USB62405/JYUSB62405DITask.cs


USB62405 C# Programming Manual: JYUSB62405.DIChannel Class Reference

  • DIChannel
Properties | List of all members
JYUSB62405.DIChannel Class Reference

DIO通道参数类 More...

Properties

int LineNum [get, set]
端口中的位号，从0开始。提供小于0的值，将获得值0. More...

Detailed Description

DIO通道参数类

Property Documentation

◆ LineNum

int JYUSB62405.DIChannel.LineNum
getset

端口中的位号，从0开始。提供小于0的值，将获得值0.

The documentation for this class was generated from the following file:
  • USB62405/JYUSB62405DITask.cs


USB62405 C# Programming Manual: USB62405/JYUSB62405DOTask.cs File Reference

  • USB62405
Classes | Namespaces
JYUSB62405DOTask.cs File Reference

Classes

class | JYUSB62405.JYUSB62405DOTask
DIO操作任务类 More...
class | JYUSB62405.DOChannel
DIO通道参数类 More...

Namespaces

namespace JYUSB62405


USB62405 C# Programming Manual: JYUSB62405.JYUSB62405DOTask Class Reference

  • JYUSB62405DOTask
Public Member Functions | Properties | List of all members
JYUSB62405.JYUSB62405DOTask Class Reference

DIO操作任务类 More...

Public Member Functions

JYUSB62405DOTask (int boardNum)
构造函数 More...
void | AddChannel (int lineNum)
添加通道 More...
void | AddChannel (int[] lineNum)
添加通道 More...
void | RemoveChannel (int lineNum)
删除指定端口号和位号的通道。位号小于0时表示删除指定端口号的所有通道。 More...
void | Start ()
开始D0任务 More...
void | Stop ()
停止D0任务 More...
void | WriteSinglePoint (bool[] Buf)
每通道更新一个点, 非缓冲式更新。 More...

Properties

List< DOChannel > Channels [get]
通道列表 More...

Detailed Description

DIO操作任务类

Constructor & Destructor Documentation

◆ JYUSB62405DOTask()

JYUSB62405.JYUSB62405DOTask.JYUSB62405DOTask ( int boardNum )

构造函数

Parameters
boardNum 板卡编号

Member Function Documentation

◆ AddChannel() [1/2]

void JYUSB62405.JYUSB62405DOTask.AddChannel ( int lineNum )

添加通道

Parameters
lineNum 位号，从0开始。
Returns

◆ AddChannel() [2/2]

void JYUSB62405.JYUSB62405DOTask.AddChannel ( int[] lineNum )

添加通道

Parameters
lineNum 位号，从0开始。
Returns

◆ RemoveChannel()

void JYUSB62405.JYUSB62405DOTask.RemoveChannel ( int lineNum )

删除指定端口号和位号的通道。位号小于0时表示删除指定端口号的所有通道。

Parameters
lineNum 端口中的位号

◆ Start()

void JYUSB62405.JYUSB62405DOTask.Start ( )

开始D0任务

Returns

◆ Stop()

void JYUSB62405.JYUSB62405DOTask.Stop ( )

停止D0任务

Returns

◆ WriteSinglePoint()

void JYUSB62405.JYUSB62405DOTask.WriteSinglePoint ( bool[] Buf )

每通道更新一个点, 非缓冲式更新。

Parameters
Buf 用户缓冲区数组, 数组大小须不小于_channels.count

用于软件定时DIO操作。

Property Documentation

◆ Channels

List<DOChannel> JYUSB62405.JYUSB62405DOTask.Channels
get

通道列表

The documentation for this class was generated from the following file:
  • USB62405/JYUSB62405DOTask.cs


USB62405 C# Programming Manual: JYUSB62405.DOChannel Class Reference

  • DOChannel
Properties | List of all members
JYUSB62405.DOChannel Class Reference

DIO通道参数类 More...

Properties

int LineNum [get, set]
端口中的位号，从0开始。提供小于0的值，将获得值0. More...

Detailed Description

DIO通道参数类

Property Documentation

◆ LineNum

int JYUSB62405.DOChannel.LineNum
getset

端口中的位号，从0开始。提供小于0的值，将获得值0.

The documentation for this class was generated from the following file:
  • USB62405/JYUSB62405DOTask.cs


USB62405 C# Programming Manual: Class List

Class List
Here are the classes, structs, unions and interfaces with brief descriptions:
[detail level 12]
▼N JYUSB62405 |
C JYUSB62405AITask | AI采集任务类,是Sealed类，不可被继承
C AIChannel | AI通道参数类
C AITrigger | 触发参数
C AIDigitalTrigger | 数字触发参数
C AIAnalogTrigger | 模拟触发参数
C AIAdvanced | AI高级参数设置
C JYUSB62405CITask | CI任务
C JYUSB62405COTask | CO操作任务类
C DutyCycleFrequency | 按占空比和频率设置
C Time | 按高低电平时间设置
C Tick | 按高低电平Tick设置
C COPulse | CO脉冲的参数设置
C JYUSB62405DITask | DIO操作任务类
C DIChannel | DIO通道参数类
C JYUSB62405DOTask | DIO操作任务类
C DOChannel | DIO通道参数类


USB62405 C# Programming Manual: Member List

  • AIAdvanced
JYUSB62405.AIAdvanced Member List

This is the complete list of members for JYUSB62405.AIAdvanced, including all inherited members.

BufferLengthInSecond JYUSB62405.AIAdvanced


USB62405 C# Programming Manual: Member List

  • AIAnalogTrigger
JYUSB62405.AIAnalogTrigger Member List

This is the complete list of members for JYUSB62405.AIAnalogTrigger, including all inherited members.

Condition | JYUSB62405.AIAnalogTrigger
Source | JYUSB62405.AIAnalogTrigger
Threshold | JYUSB62405.AIAnalogTrigger


USB62405 C# Programming Manual: Member List

  • AIChannel
JYUSB62405.AIChannel Member List

This is the complete list of members for JYUSB62405.AIChannel, including all inherited members.

ChannelID | JYUSB62405.AIChannel
Coupling | JYUSB62405.AIChannel
EnableIEPE | JYUSB62405.AIChannel
RangeHigh | JYUSB62405.AIChannel
RangeLow | JYUSB62405.AIChannel
Terminal | JYUSB62405.AIChannel


USB62405 C# Programming Manual: Member List

  • AIDigitalTrigger
JYUSB62405.AIDigitalTrigger Member List

This is the complete list of members for JYUSB62405.AIDigitalTrigger, including all inherited members.

Edge | JYUSB62405.AIDigitalTrigger
Source | JYUSB62405.AIDigitalTrigger


USB62405 C# Programming Manual: Member List

  • AITrigger
JYUSB62405.AITrigger Member List

This is the complete list of members for JYUSB62405.AITrigger, including all inherited members.

Analog | JYUSB62405.AITrigger
Delay | JYUSB62405.AITrigger
Digital | JYUSB62405.AITrigger
Mode | JYUSB62405.AITrigger
PreTriggerSamples | JYUSB62405.AITrigger
ReTriggerCount | JYUSB62405.AITrigger
Type | JYUSB62405.AITrigger


USB62405 C# Programming Manual: Member List

  • COPulse
JYUSB62405.COPulse Member List

This is the complete list of members for JYUSB62405.COPulse, including all inherited members.

Count | JYUSB62405.COPulse
DutyCycleFrequency | JYUSB62405.COPulse
InitialDelay | JYUSB62405.COPulse
Polarity | JYUSB62405.COPulse
Tick | JYUSB62405.COPulse
Time | JYUSB62405.COPulse
Type | JYUSB62405.COPulse


USB62405 C# Programming Manual: Member List

  • DIChannel
JYUSB62405.DIChannel Member List

This is the complete list of members for JYUSB62405.DIChannel, including all inherited members.

LineNum JYUSB62405.DIChannel


USB62405 C# Programming Manual: Member List

  • DOChannel
JYUSB62405.DOChannel Member List

This is the complete list of members for JYUSB62405.DOChannel, including all inherited members.

LineNum JYUSB62405.DOChannel


USB62405 C# Programming Manual: Member List

  • DutyCycleFrequency
JYUSB62405.DutyCycleFrequency Member List

This is the complete list of members for JYUSB62405.DutyCycleFrequency, including all inherited members.

DutyCycle | JYUSB62405.DutyCycleFrequency
Frequency | JYUSB62405.DutyCycleFrequency


USB62405 C# Programming Manual: Member List

  • JYUSB62405AITask
JYUSB62405.JYUSB62405AITask Member List

This is the complete list of members for JYUSB62405.JYUSB62405AITask, including all inherited members.

AddChannel(int channelID, double rangeLow=-10, double rangeHigh=10, Coupling coupling=Coupling.DC, AITerminal terminal=AITerminal.Differential, bool enableIEPE=false) | JYUSB62405.JYUSB62405AITask
AddChannel(int[] channelsID, double rangeLow=-10, double rangeHigh=10, Coupling coupling=Coupling.DC, AITerminal terminal=AITerminal.Differential, bool enableIEPE=false) | JYUSB62405.JYUSB62405AITask
AddChannel(int[] channelsID, double[] rangeLow, double[] rangeHigh, Coupling coupling=Coupling.DC, AITerminal terminal=AITerminal.Differential, bool enableIEPE=false) | JYUSB62405.JYUSB62405AITask
Advanced | JYUSB62405.JYUSB62405AITask
AvailableSamples | JYUSB62405.JYUSB62405AITask
BufLenInSamples | JYUSB62405.JYUSB62405AITask
Channels | JYUSB62405.JYUSB62405AITask
ClkSource | JYUSB62405.JYUSB62405AITask
ClockEdge | JYUSB62405.JYUSB62405AITask
JYUSB62405AITask(int boardNum) | JYUSB62405.JYUSB62405AITask
Mode | JYUSB62405.JYUSB62405AITask
ReadData(ref double[,] buf, int timeout) | JYUSB62405.JYUSB62405AITask
ReadData(ref double[,] buf, int samplesPerChannel, int timeout) | JYUSB62405.JYUSB62405AITask
ReadData(ref double[] buf, int timeout) | JYUSB62405.JYUSB62405AITask
ReadData(ref double[] buf, int samplesPerChannel, int timeout) | JYUSB62405.JYUSB62405AITask
ReadData(IntPtr buf, int samplesPerChannel, int timeout) | JYUSB62405.JYUSB62405AITask
ReadRawData(IntPtr buf, int samplesPerChannel, int timeout) | JYUSB62405.JYUSB62405AITask
ReadRawData(ref int[,] buf, int timeout) | JYUSB62405.JYUSB62405AITask
ReadRawData(ref int[,] buf, int samplesPerChannel, int timeout) | JYUSB62405.JYUSB62405AITask
ReadRawData(ref int[] buf, int timeout) | JYUSB62405.JYUSB62405AITask
ReadRawData(ref int[] buf, int samplesPerChannel, int timeout) | JYUSB62405.JYUSB62405AITask
ReadSinglePoint(ref double[] buffer) | JYUSB62405.JYUSB62405AITask
ReadSinglePoint(ref double readValue) | JYUSB62405.JYUSB62405AITask
RemoveChannel(int channelID) | JYUSB62405.JYUSB62405AITask
SampleRate | JYUSB62405.JYUSB62405AITask
SamplesToAcquire | JYUSB62405.JYUSB62405AITask
Start() | JYUSB62405.JYUSB62405AITask
Stop() | JYUSB62405.JYUSB62405AITask
Trigger | JYUSB62405.JYUSB62405AITask
WaitUntilDone(int timeout) | JYUSB62405.JYUSB62405AITask


USB62405 C# Programming Manual: Member List

  • JYUSB62405CITask
JYUSB62405.JYUSB62405CITask Member List

This is the complete list of members for JYUSB62405.JYUSB62405CITask, including all inherited members.

JYUSB62405CITask(int boardNum, int channelID) | JYUSB62405.JYUSB62405CITask
ReadCounter(ref uint buf) | JYUSB62405.JYUSB62405CITask
Start() | JYUSB62405.JYUSB62405CITask
Stop() | JYUSB62405.JYUSB62405CITask


USB62405 C# Programming Manual: Member List

  • JYUSB62405COTask
JYUSB62405.JYUSB62405COTask Member List

This is the complete list of members for JYUSB62405.JYUSB62405COTask, including all inherited members.

ApplyParam() | JYUSB62405.JYUSB62405COTask
JYUSB62405COTask(int boardNum, int chnId) | JYUSB62405.JYUSB62405COTask
Mode | JYUSB62405.JYUSB62405COTask
Pulse | JYUSB62405.JYUSB62405COTask
Start() | JYUSB62405.JYUSB62405COTask
Stop() | JYUSB62405.JYUSB62405COTask


USB62405 C# Programming Manual: Member List

  • JYUSB62405DITask
JYUSB62405.JYUSB62405DITask Member List

This is the complete list of members for JYUSB62405.JYUSB62405DITask, including all inherited members.

AddChannel(int lineNum) | JYUSB62405.JYUSB62405DITask
AddChannel(int[] lineNum) | JYUSB62405.JYUSB62405DITask
Channels | JYUSB62405.JYUSB62405DITask
JYUSB62405DITask(int boardNum) | JYUSB62405.JYUSB62405DITask
ReadSinglePoint(ref bool[] Buf) | JYUSB62405.JYUSB62405DITask
RemoveChannel(int lineNum) | JYUSB62405.JYUSB62405DITask
Start() | JYUSB62405.JYUSB62405DITask
Stop() | JYUSB62405.JYUSB62405DITask


USB62405 C# Programming Manual: Member List

  • JYUSB62405DOTask
JYUSB62405.JYUSB62405DOTask Member List

This is the complete list of members for JYUSB62405.JYUSB62405DOTask, including all inherited members.

AddChannel(int lineNum) | JYUSB62405.JYUSB62405DOTask
AddChannel(int[] lineNum) | JYUSB62405.JYUSB62405DOTask
Channels | JYUSB62405.JYUSB62405DOTask
JYUSB62405DOTask(int boardNum) | JYUSB62405.JYUSB62405DOTask
RemoveChannel(int lineNum) | JYUSB62405.JYUSB62405DOTask
Start() | JYUSB62405.JYUSB62405DOTask
Stop() | JYUSB62405.JYUSB62405DOTask
WriteSinglePoint(bool[] Buf) | JYUSB62405.JYUSB62405DOTask


USB62405 C# Programming Manual: Member List

  • Tick
JYUSB62405.Tick Member List

This is the complete list of members for JYUSB62405.Tick, including all inherited members.

High | JYUSB62405.Tick
Low | JYUSB62405.Tick


USB62405 C# Programming Manual: Member List

  • Time
JYUSB62405.Time Member List

This is the complete list of members for JYUSB62405.Time, including all inherited members.

High | JYUSB62405.Time
Low | JYUSB62405.Time


USB62405 C# Programming Manual: Class Index

Class Index
A | C | D | J | T
A
AIAdvanced (JYUSB62405)
AIAnalogTrigger (JYUSB62405)
AIChannel (JYUSB62405)
AIDigitalTrigger (JYUSB62405)
AITrigger (JYUSB62405)
C
COPulse (JYUSB62405)
D
DIChannel (JYUSB62405)
DOChannel (JYUSB62405)
DutyCycleFrequency (JYUSB62405)
J
JYUSB62405AITask (JYUSB62405)
JYUSB62405CITask (JYUSB62405)
JYUSB62405COTask (JYUSB62405)
JYUSB62405DITask (JYUSB62405)
JYUSB62405DOTask (JYUSB62405)
T
Tick (JYUSB62405)
Time (JYUSB62405)


USB62405 C# Programming Manual: File List

File List
Here is a list of all files with brief descriptions:
[detail level 12]
▼ USB62405
JYUSB62405AITask.cs
JYUSB62405CITask.cs
JYUSB62405COTask.cs
JYUSB62405DITask.cs
JYUSB62405DOTask.cs


USB62405 C# Programming Manual: Class Members

Here is a list of all class members with links to the classes they belong to:

- a -

  • AddChannel() : JYUSB62405.JYUSB62405AITask , JYUSB62405.JYUSB62405DITask , JYUSB62405.JYUSB62405DOTask
  • Advanced : JYUSB62405.JYUSB62405AITask
  • Analog : JYUSB62405.AITrigger
  • ApplyParam() : JYUSB62405.JYUSB62405COTask
  • AvailableSamples : JYUSB62405.JYUSB62405AITask

- b -

  • BufferLengthInSecond : JYUSB62405.AIAdvanced
  • BufLenInSamples : JYUSB62405.JYUSB62405AITask

- c -

  • ChannelID : JYUSB62405.AIChannel
  • Channels : JYUSB62405.JYUSB62405AITask , JYUSB62405.JYUSB62405DITask , JYUSB62405.JYUSB62405DOTask
  • ClkSource : JYUSB62405.JYUSB62405AITask
  • ClockEdge : JYUSB62405.JYUSB62405AITask
  • Condition : JYUSB62405.AIAnalogTrigger
  • Count : JYUSB62405.COPulse
  • Coupling : JYUSB62405.AIChannel

- d -

  • Delay : JYUSB62405.AITrigger
  • Digital : JYUSB62405.AITrigger
  • DutyCycle : JYUSB62405.DutyCycleFrequency
  • DutyCycleFrequency : JYUSB62405.COPulse

- e -

  • Edge : JYUSB62405.AIDigitalTrigger
  • EnableIEPE : JYUSB62405.AIChannel

- f -

  • Frequency : JYUSB62405.DutyCycleFrequency

- h -

  • High : JYUSB62405.Tick , JYUSB62405.Time

- i -

  • InitialDelay : JYUSB62405.COPulse

- j -

  • JYUSB62405AITask() : JYUSB62405.JYUSB62405AITask
  • JYUSB62405CITask() : JYUSB62405.JYUSB62405CITask
  • JYUSB62405COTask() : JYUSB62405.JYUSB62405COTask
  • JYUSB62405DITask() : JYUSB62405.JYUSB62405DITask
  • JYUSB62405DOTask() : JYUSB62405.JYUSB62405DOTask

- l -

  • LineNum : JYUSB62405.DIChannel , JYUSB62405.DOChannel
  • Low : JYUSB62405.Tick , JYUSB62405.Time

- m -

  • Mode : JYUSB62405.AITrigger , JYUSB62405.JYUSB62405AITask , JYUSB62405.JYUSB62405COTask

- p -

  • Polarity : JYUSB62405.COPulse
  • PreTriggerSamples : JYUSB62405.AITrigger
  • Pulse : JYUSB62405.JYUSB62405COTask

- r -

  • RangeHigh : JYUSB62405.AIChannel
  • RangeLow : JYUSB62405.AIChannel
  • ReadCounter() : JYUSB62405.JYUSB62405CITask
  • ReadData() : JYUSB62405.JYUSB62405AITask
  • ReadRawData() : JYUSB62405.JYUSB62405AITask
  • ReadSinglePoint() : JYUSB62405.JYUSB62405AITask , JYUSB62405.JYUSB62405DITask
  • RemoveChannel() : JYUSB62405.JYUSB62405AITask , JYUSB62405.JYUSB62405DITask , JYUSB62405.JYUSB62405DOTask
  • ReTriggerCount : JYUSB62405.AITrigger

- s -

  • SampleRate : JYUSB62405.JYUSB62405AITask
  • SamplesToAcquire : JYUSB62405.JYUSB62405AITask
  • Source : JYUSB62405.AIAnalogTrigger , JYUSB62405.AIDigitalTrigger
  • Start() : JYUSB62405.JYUSB62405AITask , JYUSB62405.JYUSB62405CITask , JYUSB62405.JYUSB62405COTask , JYUSB62405.JYUSB62405DITask , JYUSB62405.JYUSB62405DOTask
  • Stop() : JYUSB62405.JYUSB62405AITask , JYUSB62405.JYUSB62405CITask , JYUSB62405.JYUSB62405COTask , JYUSB62405.JYUSB62405DITask , JYUSB62405.JYUSB62405DOTask

- t -

  • Terminal : JYUSB62405.AIChannel
  • Threshold : JYUSB62405.AIAnalogTrigger
  • Tick : JYUSB62405.COPulse
  • Time : JYUSB62405.COPulse
  • Trigger : JYUSB62405.JYUSB62405AITask
  • Type : JYUSB62405.AITrigger , JYUSB62405.COPulse

- w -

  • WaitUntilDone() : JYUSB62405.JYUSB62405AITask
  • WriteSinglePoint() : JYUSB62405.JYUSB62405DOTask


USB62405 C# Programming Manual: Class Members - Functions

- a -

  • AddChannel() : JYUSB62405.JYUSB62405AITask , JYUSB62405.JYUSB62405DITask , JYUSB62405.JYUSB62405DOTask
  • ApplyParam() : JYUSB62405.JYUSB62405COTask

- j -

  • JYUSB62405AITask() : JYUSB62405.JYUSB62405AITask
  • JYUSB62405CITask() : JYUSB62405.JYUSB62405CITask
  • JYUSB62405COTask() : JYUSB62405.JYUSB62405COTask
  • JYUSB62405DITask() : JYUSB62405.JYUSB62405DITask
  • JYUSB62405DOTask() : JYUSB62405.JYUSB62405DOTask

- r -

  • ReadCounter() : JYUSB62405.JYUSB62405CITask
  • ReadData() : JYUSB62405.JYUSB62405AITask
  • ReadRawData() : JYUSB62405.JYUSB62405AITask
  • ReadSinglePoint() : JYUSB62405.JYUSB62405AITask , JYUSB62405.JYUSB62405DITask
  • RemoveChannel() : JYUSB62405.JYUSB62405AITask , JYUSB62405.JYUSB62405DITask , JYUSB62405.JYUSB62405DOTask

- s -

  • Start() : JYUSB62405.JYUSB62405AITask , JYUSB62405.JYUSB62405CITask , JYUSB62405.JYUSB62405COTask , JYUSB62405.JYUSB62405DITask , JYUSB62405.JYUSB62405DOTask
  • Stop() : JYUSB62405.JYUSB62405AITask , JYUSB62405.JYUSB62405CITask , JYUSB62405.JYUSB62405COTask , JYUSB62405.JYUSB62405DITask , JYUSB62405.JYUSB62405DOTask

- w -

  • WaitUntilDone() : JYUSB62405.JYUSB62405AITask
  • WriteSinglePoint() : JYUSB62405.JYUSB62405DOTask


USB62405 C# Programming Manual: Class Members - Properties

- a -

  • Advanced : JYUSB62405.JYUSB62405AITask
  • Analog : JYUSB62405.AITrigger
  • AvailableSamples : JYUSB62405.JYUSB62405AITask

- b -

  • BufferLengthInSecond : JYUSB62405.AIAdvanced
  • BufLenInSamples : JYUSB62405.JYUSB62405AITask

- c -

  • ChannelID : JYUSB62405.AIChannel
  • Channels : JYUSB62405.JYUSB62405AITask , JYUSB62405.JYUSB62405DITask , JYUSB62405.JYUSB62405DOTask
  • ClkSource : JYUSB62405.JYUSB62405AITask
  • ClockEdge : JYUSB62405.JYUSB62405AITask
  • Condition : JYUSB62405.AIAnalogTrigger
  • Count : JYUSB62405.COPulse
  • Coupling : JYUSB62405.AIChannel

- d -

  • Delay : JYUSB62405.AITrigger
  • Digital : JYUSB62405.AITrigger
  • DutyCycle : JYUSB62405.DutyCycleFrequency
  • DutyCycleFrequency : JYUSB62405.COPulse

- e -

  • Edge : JYUSB62405.AIDigitalTrigger
  • EnableIEPE : JYUSB62405.AIChannel

- f -

  • Frequency : JYUSB62405.DutyCycleFrequency

- h -

  • High : JYUSB62405.Tick , JYUSB62405.Time

- i -

  • InitialDelay : JYUSB62405.COPulse

- l -

  • LineNum : JYUSB62405.DIChannel , JYUSB62405.DOChannel
  • Low : JYUSB62405.Tick , JYUSB62405.Time

- m -

  • Mode : JYUSB62405.AITrigger , JYUSB62405.JYUSB62405AITask , JYUSB62405.JYUSB62405COTask

- p -

  • Polarity : JYUSB62405.COPulse
  • PreTriggerSamples : JYUSB62405.AITrigger
  • Pulse : JYUSB62405.JYUSB62405COTask

- r -

  • RangeHigh : JYUSB62405.AIChannel
  • RangeLow : JYUSB62405.AIChannel
  • ReTriggerCount : JYUSB62405.AITrigger

- s -

  • SampleRate : JYUSB62405.JYUSB62405AITask
  • SamplesToAcquire : JYUSB62405.JYUSB62405AITask
  • Source : JYUSB62405.AIAnalogTrigger , JYUSB62405.AIDigitalTrigger

- t -

  • Terminal : JYUSB62405.AIChannel
  • Threshold : JYUSB62405.AIAnalogTrigger
  • Tick : JYUSB62405.COPulse
  • Time : JYUSB62405.COPulse
  • Trigger : JYUSB62405.JYUSB62405AITask
  • Type : JYUSB62405.AITrigger , JYUSB62405.COPulse


USB62405 C# Programming Manual: Main Page

USB62405 C# Programming Manual Documentation


USB62405 C# Programming Manual: JYUSB62405 Namespace Reference

Classes | Enumerations
JYUSB62405 Namespace Reference

Classes

class | JYUSB62405AITask
AI采集任务类,是Sealed类，不可被继承 More...
class | AIChannel
AI通道参数类 More...
class | AITrigger
触发参数 More...
class | AIDigitalTrigger
数字触发参数 More...
class | AIAnalogTrigger
模拟触发参数 More...
class | AIAdvanced
AI高级参数设置 More...
class | JYUSB62405CITask
CI任务 More...
class | JYUSB62405COTask
CO操作任务类 More...
class | DutyCycleFrequency
按占空比和频率设置 More...
class | Time
按高低电平时间设置 More...
class | Tick
按高低电平Tick设置 More...
class | COPulse
CO脉冲的参数设置 More...
class | JYUSB62405DITask
DIO操作任务类 More...
class | DIChannel
DIO通道参数类 More...
class | JYUSB62405DOTask
DIO操作任务类 More...
class | DOChannel
DIO通道参数类 More...

Enumerations

enum class | Coupling { AC , DC }
耦合方式枚举类型 More...
enum class | AITriggerType { Immediate , Digital , Analog }
AI触发类型，需要根据板卡的实际支持情况修改 More...
enum class | AIClockEdge { Rising , Falling }
AI时钟沿类型 More...
enum class | AIDigitalTriggerEdge { Rising , Falling , Low , High }
AI触发沿类型 More...
enum class | AIDigitalTriggerSource { GPIO0 }
数字触发信号源 More...
enum class | AIAnalogTriggerSource { CH0 , CH1 , CH2 , CH3 }
模拟触发信号源 More...
enum class | AIMode { Single , Finite , Continuous }
AI工作模式枚举类型 More...
enum class | AITerminal { Differential , Pseudodifferential }
输入配置枚举类型 More...
enum class | AIClockSource { Internal , External }
时钟源类型 More...
enum class | AITriggerMode { Start , Reference , Pause }
触发模式 More...
enum class | AIAnalogTriggerCondition { AboveLevel , BelowLevel }
模拟触发的触发条件 More...
enum class | COSignalLevel { Low , High }
信号电平枚举，可选择项为low和High More...
enum class | COPolarity : ushort { LowActive = USB62405Import.GPTC_OUTPUT_LACTIVE , HighActive = USB62405Import.GPTC_OUTPUT_HACTIVE }
极性设置枚举，可选择项为LowActive和HighActive More...
enum class | COMode { ContGatedPulseGen = USB62405Import.ContGatedPulseGen , MultipleGatedPulseGen = USB62405Import.MultipleGatedPulseGen }
应用类型枚举，有8种模式，可选项为 SingleGatedPulseGen(Gate使能单脉冲生成），SingleTrigPulseGen（触发单脉冲生成）， RetrigSinglePulseGen（重触发单脉冲生成） SingleTrigContPulseGen（触发单脉冲生成），ContGatedPulseGen（Gate使能连续脉冲生成），MultipleGatedPulseGen（多门使能脉冲生成）。SingleTrigContPulseGenPWM（触发连续脉冲PWM连续脉冲生成）， ContGatedPulseGenPWM（门使能连续脉冲PWM生成） More...
enum class | COPulseType { DutyCycleFrequency , HighLowTime , HighLowTick }
CO输出脉冲参数的设置类型 More...

Enumeration Type Documentation

◆ AIAnalogTriggerCondition

enum JYUSB62405.AIAnalogTriggerCondition
strong

模拟触发的触发条件

Enumerator
AboveLevel | 高于阈值触发
BelowLevel | 低于阈值触发

◆ AIAnalogTriggerSource

enum JYUSB62405.AIAnalogTriggerSource
strong

模拟触发信号源

Enumerator
CH0 | 模拟触发通道0
CH1 | 模拟触发通道1
CH2 | 模拟触发通道2
CH3 | 模拟触发通道3

◆ AIClockEdge

enum JYUSB62405.AIClockEdge
strong

AI时钟沿类型

Enumerator
Rising | 上升沿
Falling | 下降沿

◆ AIClockSource

enum JYUSB62405.AIClockSource
strong

时钟源类型

Enumerator
Internal | 内部时钟源
External | 外部时钟源

◆ AIDigitalTriggerEdge

enum JYUSB62405.AIDigitalTriggerEdge
strong

AI触发沿类型

Enumerator
Rising | 上升沿
Falling | 下降沿
Low | 电平信号，低停止,用于暂停触发
High | 电平信号，高停止，用于暂停触发

◆ AIDigitalTriggerSource

enum JYUSB62405.AIDigitalTriggerSource
strong

数字触发信号源

Enumerator
GPIO0

GPIO0

◆ AIMode

enum JYUSB62405.AIMode
strong

AI工作模式枚举类型

Enumerator
Single | 单点方式
Finite | 有限点方式
Continuous | 连续方式

◆ AITerminal

enum JYUSB62405.AITerminal
strong

输入配置枚举类型

Enumerator
Differential | 差分模式
Pseudodifferential | 伪差分模式

◆ AITriggerMode

enum JYUSB62405.AITriggerMode
strong

触发模式

Enumerator
Start | Start触发
Reference | 参考触发
Pause | 暂停触发

◆ AITriggerType

enum JYUSB62405.AITriggerType
strong

AI触发类型，需要根据板卡的实际支持情况修改

Enumerator
Immediate | 无触发,立即开始采集
Digital | 数字触发
Analog | 模拟触发

◆ COMode

enum JYUSB62405.COMode
strong

应用类型枚举，有8种模式，可选项为 SingleGatedPulseGen(Gate使能单脉冲生成），SingleTrigPulseGen（触发单脉冲生成）， RetrigSinglePulseGen（重触发单脉冲生成） SingleTrigContPulseGen（触发单脉冲生成），ContGatedPulseGen（Gate使能连续脉冲生成），MultipleGatedPulseGen（多门使能脉冲生成）。SingleTrigContPulseGenPWM（触发连续脉冲PWM连续脉冲生成）， ContGatedPulseGenPWM（门使能连续脉冲PWM生成）

Enumerator
ContGatedPulseGen | Gate使能连续脉冲生成
MultipleGatedPulseGen | 多门使能脉冲生成

◆ COPolarity

enum JYUSB62405.COPolarity : ushort
strong

极性设置枚举，可选择项为LowActive和HighActive

Enumerator
LowActive | 低有效
HighActive | 高有效

◆ COPulseType

enum JYUSB62405.COPulseType
strong

CO输出脉冲参数的设置类型

Enumerator
DutyCycleFrequency | 用占空比和频率设置
HighLowTime | 用高电平时间和低电平时间设置
HighLowTick | 用高电平和低电平的Tick数设置

◆ COSignalLevel

enum JYUSB62405.COSignalLevel
strong

信号电平枚举，可选择项为low和High

Enumerator
Low | 低电平
High | 高电平

◆ Coupling

enum JYUSB62405.Coupling
strong

耦合方式枚举类型

Enumerator
AC | 交流耦合方式
DC | 直流耦合方式


USB62405 C# Programming Manual: Package Functions

Here is a list of all namespace members with links to the namespace documentation for each member:
  • AIAnalogTriggerCondition : JYUSB62405
  • AIAnalogTriggerSource : JYUSB62405
  • AIClockEdge : JYUSB62405
  • AIClockSource : JYUSB62405
  • AIDigitalTriggerEdge : JYUSB62405
  • AIDigitalTriggerSource : JYUSB62405
  • AIMode : JYUSB62405
  • AITerminal : JYUSB62405
  • AITriggerMode : JYUSB62405
  • AITriggerType : JYUSB62405
  • COMode : JYUSB62405
  • COPolarity : JYUSB62405
  • COPulseType : JYUSB62405
  • COSignalLevel : JYUSB62405
  • Coupling : JYUSB62405


USB62405 C# Programming Manual: Package Functions

  • AIAnalogTriggerCondition : JYUSB62405
  • AIAnalogTriggerSource : JYUSB62405
  • AIClockEdge : JYUSB62405
  • AIClockSource : JYUSB62405
  • AIDigitalTriggerEdge : JYUSB62405
  • AIDigitalTriggerSource : JYUSB62405
  • AIMode : JYUSB62405
  • AITerminal : JYUSB62405
  • AITriggerMode : JYUSB62405
  • AITriggerType : JYUSB62405
  • COMode : JYUSB62405
  • COPolarity : JYUSB62405
  • COPulseType : JYUSB62405
  • COSignalLevel : JYUSB62405
  • Coupling : JYUSB62405


USB62405 C# Programming Manual: Packages

Packages
Here are the packages with brief descriptions (if available):
[detail level 12]
▼N JYUSB62405 |
C JYUSB62405AITask | AI采集任务类,是Sealed类，不可被继承
C AIChannel | AI通道参数类
C AITrigger | 触发参数
C AIDigitalTrigger | 数字触发参数
C AIAnalogTrigger | 模拟触发参数
C AIAdvanced | AI高级参数设置
C JYUSB62405CITask | CI任务
C JYUSB62405COTask | CO操作任务类
C DutyCycleFrequency | 按占空比和频率设置
C Time | 按高低电平时间设置
C Tick | 按高低电平Tick设置
C COPulse | CO脉冲的参数设置
C JYUSB62405DITask | DIO操作任务类
C DIChannel | DIO通道参数类
C JYUSB62405DOTask | DIO操作任务类
C DOChannel | DIO通道参数类